package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(public|private|protected|static|final|abstract|synchronized|volatile)\s*([\w<>\[\]]+)\s*(\w+)\s*\(([\w\s\w,<>\[\]]*)?\)\s*(\bthrows\b)?[\s\w\s,\w]*\{[\n\t]*(.+)[\n\t]*((return|throw){1}\s*)(\w*)\s*;\s*[\}]`)
var str = `public boolean test(String fsdfds)
{
boolean boolean = Service.GLP.equals(somevariable.getserviceType());
return boolean;
}
public static String replaceContentOfFile(String fileContent, String regex, String replace) {
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(fileContent);
final String result = matcher.replaceAll(replace);
return result;
}
public boolean test2(String fsdfds)
{
boolean boolean = Service.GLP.equals(somevariable.getserviceType());
return boolean;
}`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}