import Foundation
let pattern = #":\D{8}\d{2}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1:nlcbjduy14 <- I want regex to find this one
2:Peoples123 <- I don't want regex to find this one, as it has 3 digits.
3:sqourzyr17 <- I want regex to find this one
4:rdmaszgr94 <- I want regex to find this one
5:tnwiudic22 <- I want regex to find this one
6:zfcxmkrs21 <- I want regex to find this one
7:xrwhsgno55 <- I want regex to find this one
8:modtwtrr06 <- I want regex to find this one
9:People123 <- I don't want regex to find this one, as it is isn't 10 chars long and it consists of 3 digits.
10:aetmyqqh52 <- I want regex to find this one
11:Howtocodelikeapro12 <- I don't want regex to find this one, as it is isn't 10 chars long
12:netphvib58 <- I want regex to find this one
13:uwyiqhoj29 <- I want regex to find this one
14:RegexJustiIsntDoingItForMe
15:qyeiaecj27 <- I want regex to find this one
16:buttercake <- I don't want regex to find this one, as it doesn't end with 2 digits.
17:bcyiyjdm23 <- I want regex to find this one
18:Differings <- I don't want regex to find this one, as it doesn't end with 2 digits.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)