import re
regex = re.compile(r"^XXX-\d{4}-((?![XYT])[A-Z]){4}$", flags=re.MULTILINE)
test_str = ("XXX-0000-XBCD\n"
"XXX-0000-AXCD\n"
"XXX-0000-ABXD\n"
"XXX-0000-ABCX\n"
"XXX-0000-XXCD\n"
"XXX-0000-XBXD\n"
"XXX-0000-XBCX\n"
"XXX-0000-AXXD\n"
"XXX-0000-AXCX\n"
"XXX-0000-ABXX\n"
"XXX-0000-XXXX\n"
"XXX-0000-AB1D\n"
"XXX-0000-A%CD\n"
"XXX-0000-ABCDE\n"
"XXX-0000-ABCDX\n"
"AXXX-0000-ABCD\n"
"XXX-A0000-ABCD\n"
"XXX-0000-ABCD\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")