const regex = /(?<hours>[0-9]{1,2}h)[ ]*(?<minutes>[0-9]{1,2}min):\s*(?<description>(?:.(?!\dh\s\d{1,2}min))+)/mgs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<hours>[0-9]{1,2}h)[ ]*(?<minutes>[0-9]{1,2}min):\\s*(?<description>(?:.(?!\\dh\\s\\d{1,2}min))+)', 'mgs')
const str = `1h 30min: Title
- Description Line 1
1h 32min: SEOND TITLE
- Description Line 1
- Description Line 2
- Description Line 3
1h 14min: Title
- another Great one 2h 42min: Title - Great Movie
- Description Line 2
- Description Line 3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}