re = /(?<hours>[0-9]{1,2}h)[ ]*(?<minutes>[0-9]{1,2}min):\s*(?<description>(?:.(?!\dh\s\d{1,2}min))+)/m
str = '1h 30min: Title
- Description Line 1
1h 32min: SEOND TITLE
- Description Line 1
- Description Line 2
- Description Line 3
1h 14min: Title
- another Great one 2h 42min: Title - Great Movie
- Description Line 2
- Description Line 3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end