$re = '/^(?:https?:\/\/)?(?:www\.)?(?:.+?)\.mp4$/i';
$str = 'http://commondatastorage.googleapis.com/gtv-videos-bucket/sample/ForBiggerFun.mp4';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);