import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b0\\d{5}\\s\\d{5}\\b|\\b[1-9]\\d{4}\\s\\d{5}\\b|\\b0\\d{10}\\b|\\b[1-9]\\d{9}\\b";
final String string = "1234567890\n"
+ "01234567890\n"
+ "12345 67890\n"
+ "012345 67890\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}