re = /\b0\d{5}\s\d{5}\b|\b[1-9]\d{4}\s\d{5}\b|\b0\d{10}\b|\b[1-9]\d{9}\b/m
str = '1234567890
01234567890
12345 67890
012345 67890
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end