package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\S+@\w+\.\w+$`)
var str = `example@example.com
example@gmail.com
example@example.co.fr
john@smith.org
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}