const regex = /^[\w\-\.]+@([\w-]+\.)+[\w-]{2,}\:[\S\-\.]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\w\\-\\.]+@([\\w-]+\\.)+[\\w-]{2,}\\:[\\S\\-\\.]+$', 'gm')
const str = `example@example.com:sdfswe12312
example@gmail.com:sdfswe12312
example@example.co.fr:sdfswe12312
example@example.co.uk:sdfswe12312
john@smith.org::sdfswe12312
0-day@bk.ru:nob0dy
0-fpavs98-ref13@mail.ru:ref123456789
0-frajer@gazeta.pl:forktest1221
0-gun@live.nl:bokto12
0-i@ulmb.com:aq1sw2
0-lens@gmail.com:43867799ABC
0-mentor@bol.com.br:102030wi
0-tomac-0@mail.ru:vjq1994
0.0.0.vadim.0.0.0@gmail.com:ValsV199I
0.0.0.web.host@yahoo.com:kZ1X1Vc1vT
0.00webhostjeff@gmail.com:p95donkey
0.03-3f@sapo.pt:SP@Q_]3w0BE&a-{
0.0@fl-de.com:hggi123
0.0@live.com:sxh3321100
0.0_robert_0.0@live.com:robert1992
0.0asd123@163.com:sls26355`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}