use strict;
my $str = 'example@example.com:sdfswe12312
example@gmail.com:sdfswe12312
example@example.co.fr:sdfswe12312
example@example.co.uk:sdfswe12312
john@smith.org::sdfswe12312
0-day@bk.ru:nob0dy
0-fpavs98-ref13@mail.ru:ref123456789
0-frajer@gazeta.pl:forktest1221
0-gun@live.nl:bokto12
0-i@ulmb.com:aq1sw2
0-lens@gmail.com:43867799ABC
0-mentor@bol.com.br:102030wi
0-tomac-0@mail.ru:vjq1994
0.0.0.vadim.0.0.0@gmail.com:ValsV199I
0.0.0.web.host@yahoo.com:kZ1X1Vc1vT
0.00webhostjeff@gmail.com:p95donkey
0.03-3f@sapo.pt:SP@Q_]3w0BE&a-{
0.0@fl-de.com:hggi123
0.0@live.com:sxh3321100
0.0_robert_0.0@live.com:robert1992
0.0asd123@163.com:sls26355';
my $regex = qr/^[\w\-\.]+@([\w-]+\.)+[\w-]{2,}\:[\S\-\.]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}