import re
regex = re.compile(r"\"([^\"]+)\":\s*(\"[^\"]+|\[[^]]*\]|\d+)", flags=re.MULTILINE)
test_str = "{\"kind\":\"Event\",\"stage\":\"ResponseComplete\",\"requestURI\":\"/api/v1/namespaces/jej/endpoints/eji.com-aws-eji\",\"verb\":\"update\",\"user\":{\"username\":\"system:serviceaccount:efs:efs-provisioner\",\"uid\":\"ab5d27b4c-71a4f77323b0\",\"groups\":[\"system:serviceaccounts\",\"system:serviceaccounts:eji\",\"system:authenticated\"]},\"sourceIPs\":[\"10.0.0.0\"],\"userAgent\":\"eji-provisioner/v0.0.0 (linux/amd64) kubernetes/$Format\",\"objectRef\":{\"resource\":\"endpoints\",\"namespace\":\"edd\",\"name\":\"dds.com-aws-edds\",\"uid\":\"44ad8-899f-fbc1f4befb2f\",\"apiVersion\":\"v1\",\"resourceVersion\":\"8852157\"},\"responseStatus\":{\"metadata\":{},\"code\":200}}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")