// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"([^"]+)":\s*("[^"]+|\[[^]]*\]|\d+)"#).unwrap();
let string = "{\"kind\":\"Event\",\"stage\":\"ResponseComplete\",\"requestURI\":\"/api/v1/namespaces/jej/endpoints/eji.com-aws-eji\",\"verb\":\"update\",\"user\":{\"username\":\"system:serviceaccount:efs:efs-provisioner\",\"uid\":\"ab5d27b4c-71a4f77323b0\",\"groups\":[\"system:serviceaccounts\",\"system:serviceaccounts:eji\",\"system:authenticated\"]},\"sourceIPs\":[\"10.0.0.0\"],\"userAgent\":\"eji-provisioner/v0.0.0 (linux/amd64) kubernetes/$Format\",\"objectRef\":{\"resource\":\"endpoints\",\"namespace\":\"edd\",\"name\":\"dds.com-aws-edds\",\"uid\":\"44ad8-899f-fbc1f4befb2f\",\"apiVersion\":\"v1\",\"resourceVersion\":\"8852157\"},\"responseStatus\":{\"metadata\":{},\"code\":200}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}