import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z]+>";
final String string = " <gcusf><gcusfname>SEND-SU-01</gcusfname>\n"
+ "<gcusfvalue>'||\"TO CHECK AUTOMATIC DISCART FOR USER\"'</gc\n"
+ "usfvalue>\n"
+ " </gcusf>\n"
+ " <gcrvalf>YYMMDD</gcrvalf><gcrvalt>YYMMDD</gcrvalt>\n"
+ "<gcrundesc>'MY DESC YYMMDD -L2,-L4,-L5 OF WEEK'</gcrunde\n"
+ "sc><gcrunrule>E</gcrunrule><gcrtype>N</gcrtype><gcriat>2300</gcriat>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}