// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z]+>").unwrap();
let string = " <gcusf><gcusfname>SEND-SU-01</gcusfname>
<gcusfvalue>'||\"TO CHECK AUTOMATIC DISCART FOR USER\"'</gc
usfvalue>
</gcusf>
<gcrvalf>YYMMDD</gcrvalf><gcrvalt>YYMMDD</gcrvalt>
<gcrundesc>'MY DESC YYMMDD -L2,-L4,-L5 OF WEEK'</gcrunde
sc><gcrunrule>E</gcrunrule><gcrtype>N</gcrtype><gcriat>2300</gcriat>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}