$re = '/\((\d+).+\)/m';
$str = '5 дней (32 ак. часа) с 10.00 до 14.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);