const regex = new RegExp('\\[(\\[?)(.*?)(?![\\w-])([^\\]/]*(?:/(?!\\])[^\\]/]*)*?)(?:(/)\\]|\\](?:([^\\[]*(?:\\[(?!/\\2\\])[^\\[]*)*)(\\[/\\2\\]))?)(\\]?)', '')
const str = `This is a test [example attr1="test1" attr2="test2"]content
over multiple
lines with a random[shortcode] inside[/example]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}