#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mui)^(?:[[:alpha:]]|[ \-\'])+$"
Local $sString = "Alexander" & @CRLF & _
"Musin-Pushkin" & @CRLF & _
"D'Artagnan" & @CRLF & _
"Александр" & @CRLF & _
"Тёркин" & @CRLF & _
"François" & @CRLF & _
"Maček" & @CRLF & _
"José" & @CRLF & _
"Jürgen" & @CRLF & _
"Жан жак" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")