re = /^(?:[[:alpha:]]|[ \-\'])+$/mi
str = 'Alexander
Musin-Pushkin
D\'Artagnan
Александр
Тёркин
François
Maček
José
Jürgen
Жан жак
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end