#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\-(?:dev|qa)[0-9]*[ab]"
Local $sString = "" & @CRLF & _
"baamid-admin-api-ecs-service-dev" & @CRLF & _
"baamid-admin-api-ecs-service-qa" & @CRLF & _
"baamid-admin-api-ecs-service-qb" & @CRLF & _
"baamid-admin-api-ext-ecs-service-dev" & @CRLF & _
"baamid-admin-api-ext-ecs-service-qb" & @CRLF & _
"bxid-duende-ecs-service-dev" & @CRLF & _
"bxid-duende-ecs-service-qa" & @CRLF & _
"bxid-duende-ecs-service-qb" & @CRLF & _
"bxid-ecs-service-dev" & @CRLF & _
"bxid-ecs-service-qa" & @CRLF & _
"bxid-ecs-service-qb" & @CRLF & _
"bxid-ext-ecs-service-dev" & @CRLF & _
"bxid-ext-ecs-service-m-dev" & @CRLF & _
"bxid-ext-ecs-service-m-qa" & @CRLF & _
"bxid-ext-ecs-service-m-qb" & @CRLF & _
"bxid-ext-ecs-service-qa" & @CRLF & _
"bxid-ext-ecs-service-qb" & @CRLF & _
"policy-server-admin-ecs-service-dev" & @CRLF & _
"policy-server-admin-ecs-service-qa" & @CRLF & _
"policy-server-admin-ecs-service-qb" & @CRLF & _
"policy-server-agent-api-dev" & @CRLF & _
"policy-server-agent-api-qa" & @CRLF & _
"policy-server-agent-api-qb" & @CRLF & _
"policy-server-ecs-service-dev" & @CRLF & _
"policy-server-ecs-service-m-dev" & @CRLF & _
"policy-server-ecs-service-m-qa" & @CRLF & _
"policy-server-ecs-service-m-qb" & @CRLF & _
"policy-server-ecs-service-qa" & @CRLF & _
"policy-server-ecs-service-qb" & @CRLF & _
"userprofilesservice-dev" & @CRLF & _
"userprofilesservice-ecs-service-qa" & @CRLF & _
"userprofilesservice-ecs-service-qa1a" & @CRLF & _
"userprofilesservice-ecs-service-qa2a" & @CRLF & _
"userprofilesservice-ecs-service-qa33a" & @CRLF & _
"userprofilesservice-ecs-service-qa5b" & @CRLF & _
"userprofilesservice-ecs-service-qb" & @CRLF & _
"userprofilesservice-ecs-service_r1" & @CRLF & _
"userprofilesservice-ecs-service_r2" & @CRLF & _
"userprofilesservice-ecs-service_x" & @CRLF & _
"userprofilesservice-ecs-service_y"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")