# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\-(?:dev|qa)[0-9]*[ab]"
test_str = ("\n"
"baamid-admin-api-ecs-service-dev\n"
"baamid-admin-api-ecs-service-qa\n"
"baamid-admin-api-ecs-service-qb\n"
"baamid-admin-api-ext-ecs-service-dev\n"
"baamid-admin-api-ext-ecs-service-qb\n"
"bxid-duende-ecs-service-dev\n"
"bxid-duende-ecs-service-qa\n"
"bxid-duende-ecs-service-qb\n"
"bxid-ecs-service-dev\n"
"bxid-ecs-service-qa\n"
"bxid-ecs-service-qb\n"
"bxid-ext-ecs-service-dev\n"
"bxid-ext-ecs-service-m-dev\n"
"bxid-ext-ecs-service-m-qa\n"
"bxid-ext-ecs-service-m-qb\n"
"bxid-ext-ecs-service-qa\n"
"bxid-ext-ecs-service-qb\n"
"policy-server-admin-ecs-service-dev\n"
"policy-server-admin-ecs-service-qa\n"
"policy-server-admin-ecs-service-qb\n"
"policy-server-agent-api-dev\n"
"policy-server-agent-api-qa\n"
"policy-server-agent-api-qb\n"
"policy-server-ecs-service-dev\n"
"policy-server-ecs-service-m-dev\n"
"policy-server-ecs-service-m-qa\n"
"policy-server-ecs-service-m-qb\n"
"policy-server-ecs-service-qa\n"
"policy-server-ecs-service-qb\n"
"userprofilesservice-dev\n"
"userprofilesservice-ecs-service-qa\n"
"userprofilesservice-ecs-service-qa1a\n"
"userprofilesservice-ecs-service-qa2a\n"
"userprofilesservice-ecs-service-qa33a\n"
"userprofilesservice-ecs-service-qa5b\n"
"userprofilesservice-ecs-service-qb\n"
"userprofilesservice-ecs-service_r1\n"
"userprofilesservice-ecs-service_r2\n"
"userprofilesservice-ecs-service_x\n"
"userprofilesservice-ecs-service_y")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.