package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{4}\/\d{6}(\/\d{3})?$`)
var str = `4444/666666333
4444/666666/
4444/666666/123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}