import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\d?(\\d\\d)\\1{3})\\d{9}$";
final String string = "561616161\n"
+ "121212123\n"
+ "411111111\n"
+ "111111114\n\n"
+ "111111111\n"
+ "299887766\n"
+ "887756564\n"
+ "123412345\n"
+ "123123123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}