#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Group\sMembership:\s+(([A-Za-z0-9-_]+\\)((?<test>[A-Za-z0-9-_ ]+))\s+)"
Local $sString = "Subject:" & @CRLF & _
" Security ID:" & @CRLF & _
" Account Name:" & @CRLF & _
" Account Domain:" & @CRLF & _
" Logon ID:" & @CRLF & _
"" & @CRLF & _
"Logon Type: 3" & @CRLF & _
"" & @CRLF & _
"New Logon:" & @CRLF & _
" Security ID: ABC\SH07" & @CRLF & _
" Account Name: SH07" & @CRLF & _
" Account Domain: ABC" & @CRLF & _
" Logon ID: 0xEB7A5403" & @CRLF & _
"" & @CRLF & _
"Event in sequence: 1 of 1" & @CRLF & _
"" & @CRLF & _
"Group Membership:" & @CRLF & _
" ABC\Domain Users " & @CRLF & _
" Everyone " & @CRLF & _
" BUILTIN\Users " & @CRLF & _
" NT AUTHORITY\NETWORK " & @CRLF & _
" NT AUTHORITY\Authenticated Users " & @CRLF & _
" NT AUTHORITY\This Organization " & @CRLF & _
" ABC\FS-ABCDEFG-Workspaces_CS-Production-WIP_MODIFY " & @CRLF & _
" ABC\FS-ABCDEFG-Workspaces_CS-EntertainmentDesign-WIP_READ" & @CRLF & _
" ABC\FS-ABCDEFG-Wspaces_CS-Print-WIP_READ " & @CRLF & _
" ABC\Workstations-Desktop-Add Remove " & @CRLF & _
" ABC\FS-ABCDEFG-Wpaces_CS-Imagery-WIP_READ " & @CRLF & _
" Authentication authority asserted identity " & @CRLF & _
" ABC\APP-JDE-123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")