import re
regex = re.compile(r"Group\sMembership:\s+(([A-Za-z0-9-_]+\\)((?<test>[A-Za-z0-9-_ ]+))\s+)", flags=re.MULTILINE)
test_str = ("Subject:\n"
" Security ID:\n"
" Account Name:\n"
" Account Domain:\n"
" Logon ID:\n\n"
"Logon Type: 3\n\n"
"New Logon:\n"
" Security ID: ABC\\SH07\n"
" Account Name: SH07\n"
" Account Domain: ABC\n"
" Logon ID: 0xEB7A5403\n\n"
"Event in sequence: 1 of 1\n\n"
"Group Membership:\n"
" ABC\\Domain Users \n"
" Everyone \n"
" BUILTIN\\Users \n"
" NT AUTHORITY\\NETWORK \n"
" NT AUTHORITY\\Authenticated Users \n"
" NT AUTHORITY\\This Organization \n"
" ABC\\FS-ABCDEFG-Workspaces_CS-Production-WIP_MODIFY \n"
" ABC\\FS-ABCDEFG-Workspaces_CS-EntertainmentDesign-WIP_READ\n"
" ABC\\FS-ABCDEFG-Wspaces_CS-Print-WIP_READ \n"
" ABC\\Workstations-Desktop-Add Remove \n"
" ABC\\FS-ABCDEFG-Wpaces_CS-Imagery-WIP_READ \n"
" Authentication authority asserted identity \n"
" ABC\\APP-JDE-123")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")