#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "jsonp\.php\?([^"]+)"
Local $sString = "$.getJSON("http://www.foo.com/jsonp.php?scode=1459256535&artist=bar tar zar&alb=Album&repeat=list&autostart=true&sw=", (function(data)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")