$re = '/jsonp\.php\?([^"]+)/';
$str = '$.getJSON("http://www.foo.com/jsonp.php?scode=1459256535&artist=bar tar zar&alb=Album&repeat=list&autostart=true&sw=", (function(data)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);