$re = '/\w+(?<!\\\\\\\\)=/';
$str = 'metadata=1.2 name=ston\\\\=e:su pershare UUID=eff4e7bc:47aea5cf:0f0560f0:2de38475';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);