$re = '/[A-Z]?[a-z]+|[A-Z]|[0-9]+/m';
$str = 'ANet15Amount';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);