re = /"[^"]*",(*SKIP)(*F)|.+/m
str = '"buckeye",
"buckeye"
,
."
,"
"fbfdb
"feve,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end