$re = '/^(?=.*?[a-z])(?:(?=.*?[0-9])|(?=.*?[#?!@$%^&*-])).{7,}$/m';
$str = 'onedigit1
onespch%
nodigits
nospchs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);