re = /^(?=.*?[a-z])(?:(?=.*?[0-9])|(?=.*?[#?!@$%^&*-])).{7,}$/m
str = 'onedigit1
onespch%
nodigits
nospchs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end