package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\/[(a-z\-)]+\/[(0-9)]+\/?+$`)
var str = `/testing-my-slug/(54656)/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}