$re = '/^\/[(a-z\-)]+\/[(0-9)]+\/?+$/';
$str = '/testing-my-slug/(54656)/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);