using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"workmail: mail:\s*([^@>;]*)";
string input = @"homemail: mail:username@mail.com
workmail: mail:username@mail.com
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}