using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^([^?]*)|([^?]*)$)";
string input = @"search.php?make=8&vehicle_type=car&location_path=used&sort=nis&p=";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}