$re = '/(^([^?]*)|([^?]*)$)/';
$str = 'search.php?make=8&vehicle_type=car&location_path=used&sort=nis&p=';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);