package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{2}[.\/-]\d{2}[.\/-]\d{4}$`)
var str = `22-03-1981`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}