$re = '/^\d{2}[.\/-]\d{2}[.\/-]\d{4}$/m';
$str = '22-03-1981';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);