import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ErrorDescription=\"(.+?)\"";
final String string = " <Errors>\n"
+ " <Error ErrorCode=\"ERR_0139\"\n"
+ " ErrorDescription=\"Cannot Find Person For Given Order.\" ErrorMoreInfo=\"\">\n"
+ " ...\n"
+ " ...\n"
+ "</Error>\n"
+ " </Errors>\n"
+ "<Errors>\n"
+ " <Error ErrorCode=\"Code\" ErrorDescription=\"Description\" ErrorInfo=\"\" ErrorId=\"ID\">\n"
+ " <Attribute Name=\"ErrorCode\" Value=\"Code\"/>\n"
+ " <Attribute Name=\"ErrorDescription\" Value=\"Description\"/>\n"
+ " <Attribute Name=\"Key\" Value=\"Key\"/>\n"
+ " <Attribute Name=\"Number\" Value=\"Number\"/>\n"
+ " <Attribute Name=\"ErrorId\" Value=\"ID\"/>\n"
+ " <Attribute Name=\"UserId\" Value=\"User\"/>\n"
+ " <Attribute Name=\"ProgId\" Value=\"Prog\"/>\n"
+ " <Stack>typical Java stack</Stack>\n"
+ " </Error>\n"
+ " <Error>\n"
+ " Similar info to the above\n"
+ " </Error>\n"
+ "</Errors>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}