// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)ErrorDescription="(.+?)""#).unwrap();
let string = " <Errors>
<Error ErrorCode=\"ERR_0139\"
ErrorDescription=\"Cannot Find Person For Given Order.\" ErrorMoreInfo=\"\">
...
...
</Error>
</Errors>
<Errors>
<Error ErrorCode=\"Code\" ErrorDescription=\"Description\" ErrorInfo=\"\" ErrorId=\"ID\">
<Attribute Name=\"ErrorCode\" Value=\"Code\"/>
<Attribute Name=\"ErrorDescription\" Value=\"Description\"/>
<Attribute Name=\"Key\" Value=\"Key\"/>
<Attribute Name=\"Number\" Value=\"Number\"/>
<Attribute Name=\"ErrorId\" Value=\"ID\"/>
<Attribute Name=\"UserId\" Value=\"User\"/>
<Attribute Name=\"ProgId\" Value=\"Prog\"/>
<Stack>typical Java stack</Stack>
</Error>
<Error>
Similar info to the above
</Error>
</Errors>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}