re = /^([^#?\n]+)(?:\?((?:[^#\n])+))?(?:#(.*))?$/m
str = 'path?foo=67
path?foo=67&bar=hello
path?bar=bye&foo=1&baz=12
path?bar=123
path
path#anchor
path?bar=bye#&foo=123
path?bar=bye&foo=-123#&foo=123
path?foo=37signals
path?foo=-8
something?foo=1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end