// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^#?\n]+)(?:\?((?:[^#\n])+))?(?:#(.*))?$").unwrap();
let string = "path?foo=67
path?foo=67&bar=hello
path?bar=bye&foo=1&baz=12
path?bar=123
path
path#anchor
path?bar=bye#&foo=123
path?bar=bye&foo=-123#&foo=123
path?foo=37signals
path?foo=-8
something?foo=1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}