using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"F\[(?:[^\[\]]+|\[(?:[^\[\]]+|\[[^\[\]]*\])*\])*\]";
string input = @"1
let txt = F[aaa( F[ccc(2,2,2)],0,0)] otra texto F[bbb(1,1,1)]
2
let txt = F[aaa( F[ccc( F[ddd(3,3,3)],2,2)],0,0)] otra texto F[bbb(1,1,1)]
3
let txt = F[aaa( F[ccc( F[ddd( F[eee(7,7,7)],3,3)],2,2)],0,0)] otra texto F[bbb(1,1,1)]
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}