re = /F\[(?:[^\[\]]+|\[(?:[^\[\]]+|\[[^\[\]]*\])*\])*\]/
str = '1
let txt = F[aaa( F[ccc(2,2,2)],0,0)] otra texto F[bbb(1,1,1)]
2
let txt = F[aaa( F[ccc( F[ddd(3,3,3)],2,2)],0,0)] otra texto F[bbb(1,1,1)]
3
let txt = F[aaa( F[ccc( F[ddd( F[eee(7,7,7)],3,3)],2,2)],0,0)] otra texto F[bbb(1,1,1)]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end