re = /(?<=pies\n|\G,\n)(\w+ likes)/m
str = 'pies
bob likes,
larry likes,
harry likes
cakes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end