#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)(my_folder/(?:[^/\n]+/)*[^/\n]+\.xml)::(?!.*\1)"
Local $sString = " my_folder/foo.xml::someextracontent" & @CRLF & _
" my_folder/foo.xml::someextracontent" & @CRLF & _
" another_folder/foo.xml::someextracontent" & @CRLF & _
" my_folder/bar.xml::someextracontent" & @CRLF & _
" my_folder/bar.xml::someextracontent" & @CRLF & _
" my_folder/hello.xml::someextracontent" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"my_folder/test1/test2/bar.xml::someextracontent" & @CRLF & _
"my_folder/test1/test2/bar.xml::someextracontent"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")