$re = '~(?s)(my_folder/(?:[^/\n]+/)*[^/\n]+\.xml)::(?!.*\1)~m';
$str = ' my_folder/foo.xml::someextracontent
my_folder/foo.xml::someextracontent
another_folder/foo.xml::someextracontent
my_folder/bar.xml::someextracontent
my_folder/bar.xml::someextracontent
my_folder/hello.xml::someextracontent
my_folder/test1/test2/bar.xml::someextracontent
my_folder/test1/test2/bar.xml::someextracontent';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);