import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w{3,8}-\\w{3,8}$";
final String string = "Text-Text\n"
+ "Abc-123\n"
+ "123-Abc\n"
+ "A2C-def4gk\n\n"
+ "Ab-3\n"
+ "Abc!-ajr4\n"
+ "a-bc3-25aj\n"
+ "a?c-b%";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}