re = /^\w{3,8}-\w{3,8}$/m
str = 'Text-Text
Abc-123
123-Abc
A2C-def4gk
Ab-3
Abc!-ajr4
a-bc3-25aj
a?c-b%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end